Jump to content

WYCLEF Gig not working - Help!


Recommended Posts

I’ve tried submitting my application for the Wyclef gig several times using different browsers and each time I fill out the application then click SUBMIT, nothing happens…


Not sure what’s going on, anyone else experiencing this issue? Any advice would be much appreciated


Link to comment
Share on other sites

Reach out to CS to let them know you’re having issues.


Hopefully, they get it sorted quickly because

Apply until August 9th, 11:59pm EST

Thanks for the prompt response Nika…

Forgot to mention that I already submitted a ticket on my original post but I finally got my application over!

Here’s what I did for anyone else experiencing the same issue… I simply tried Opera (browser) and it worked, not sure why Chrome, FireFox, or Edge didn’t do the trick but my application is now submitted!

Good Day!

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...