Jump to content
  • 1

Can't get past w9 screen. Any advice?


jqhypnosis

Question

I am new to fiverr and have been trying to post my first gig. I complete each step and then the final stage where it says "You're almost done!" I am asked to complete W9 forms. I read over the information on it again and it just says "you submitted your W9 on 08/16/23". The "post gig" option remains greyed out and only the green "next" button is available to me. When I hit that it just takes me right back to page 1 to review my gig post. Not sure what else to do.

"

Screenshot 2023-08-16 at 4.37.48 PM.png

  • Like 11
Link to comment
Share on other sites

9 answers to this question

Recommended Posts

  • 1

This is happening to me.  I followed the advice to re-do the autofills and have now filled out the w9 multiple times correctly by typing.  Has anyone got other ideas for getting past this block or contacting the right person or bot at customer service?

  • Like 1
Link to comment
Share on other sites

  • 0
28 minutes ago, jqhypnosis said:

I am new to fiverr and have been trying to post my first gig. I complete each step and then the final stage where it says "You're almost done!" I am asked to complete W9 forms. I read over the information on it again and it just says "you submitted your W9 on 08/16/23". The "post gig" option remains greyed out and only the green "next" button is available to me. When I hit that it just takes me right back to page 1 to review my gig post. Not sure what else to do.

"

Screenshot 2023-08-16 at 4.37.48 PM.png

Review W-9 Submission. Since the issue seems to be related to the W-9 form, make sure that you have correctly filled out and submitted the W-9 form. If there was an error in your submission, it could be causing the problem.

  • Like 8
  • Thanks 1
Link to comment
Share on other sites

  • 0

I was having issues with one of the required fields saying required and although i filled it out multiple times it wouldn't let me move forward. What I ended up finding is that I had autofill on a lot of forms so i was just trying to update the zip code since that's the one that ended up saying i was missing. I reselected United States instead of using my auto population which then promoted the state field to populate and it wasn't doing that originally. once i finally filled that out, i was able to get past the form.

  • Like 2
Link to comment
Share on other sites

  • 0
33 minutes ago, merihaits said:

This is happening to me.  I followed the advice to re-do the autofills and have now filled out the w9 multiple times correctly by typing.  Has anyone got other ideas for getting past this block or contacting the right person or bot at customer service?

Same here! Maybe a site problem?

  • Like 3
Link to comment
Share on other sites

  • 0
36 minutes ago, merihaits said:

This is happening to me.  I followed the advice to re-do the autofills and have now filled out the w9 multiple times correctly by typing.  Has anyone got other ideas for getting past this block or contacting the right person or bot at customer service?

Okay, I just got an email saying that the W9 is under review? so i think we have to wait 🙄

  • Like 2
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...