Jump to content
  • 0

DAC7 form "failed to submit"


litcornerbooks

Question

Hello. 

I have a problem with the new form that has to be filled. The DAC7 form that contains the name of the individual or company, the date of birth, the TIN number, the address and so on... Whenever I try to submit the correct data (I am sure they are correct, my TIN is 100% fine) the form shows "failed to submit, please try again later." Or this text appears:

We couldn’t verify the details you entered. Make sure you’ve correctly marked yourself as an individual or company, and check to make sure your TIN and name appear correctly.

When I choose the option that I do not have a TIN number, the form accepts it and I receive the message that I am compliant and no further action is required. But I still would like to have my TIN registered here as I run my small business and Fiverr is part of my working space. I am in contact with the customer support and they say they are dealing with this problem. 

But maybe someone here had the same trouble and found a way to solve it.

Thank you :)

  • Like 4
  • Up 1
Link to comment
Share on other sites

2 answers to this question

Recommended Posts

  • 0

Hi, yes. You need to register as a company, not an individual entrepreneur. It does not make sense a bit, since in my language, there is a difference between one person business and a company. A company usually means more people in the same business registration. After I marked "company" it worked for me, I was able to submit all the identification numbers and it was accepted.

  • Like 3
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...