Jump to content
  • 0

My Second Gig Won't Finish The Creation Process, Stuck In Draft…



Greetings Everyone!

I'm a new seller and published my first gig! When trying to create my second gig, I keep getting stuck at the first phase of the process. Everything is filled out correctly, but when I click on the "Save & Continue" button, I get hit with the error message at the top of the screen: "We're sorry, but the gig failed to save. Please save it again."

I'm at a loss here. Fiverr Support is really not helping me on this issue. Two different support techs on 2 tickets that I've opened was asking me the same question saying if I'm able to upload a gig image to the gallery. The answer is no, because I can't even get past the "Overview" page to even get to the "Gallery" page to even upload an image. Plus, the site does not let bypass or skip phases of the creation process for me to even do that. If there is a workaround to do so, please feel free to let me know!

So last night, I tried a third time to open a ticket. The third immediately linked the ticket to my previous ticket and closed it when that ticket wasn't truly solved. This is getting really annoying and frustrating. I am in serious need of some help and advice here.

If anyone has been through this same thing, please feel free to drop some help, hints, advice, …smoke signals…something!!!


Screenshot 2023-02-08 at 10.11.01 AM.png

  • Like 3
Link to comment
Share on other sites

4 answers to this question

Recommended Posts

  • 0


Thanks venonusa for your insight! I figured it out and I couldn't believe that I didn't about this sooner. So…I did try to edit the gig in Safari and not chrome, and it worked! I was bummed out because chrome is my default browser and I don't want to import my bookmarks to Safari. I had a random idea and was thinking, "What if I disable my Adblock extension…"

Sure enough, that was the fix…smh. I disabled it in chrome for the entire Fiverr domain and everything is working the way that it should now!

Frustration finally over…!

  • Like 2
Link to comment
Share on other sites

  • 0
1 hour ago, venonusa said:

I think it happened to me once, you have to create a new gig, copy all information to new gig also, use google chrome, it gave me that error when i was using safari

That's weird because I was using google chrome when it gave me this error. Maybe I should try Safari instead??

  • Like 1
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...