Jump to content

Fiverr is very unresponsive and buggy


balonko
 Share

Recommended Posts

I've just started selling on Fiverr, and was pretty happy on how it went. But, after a day or two, there were major flaws. Every single popup box disables page navigation, even if clicked on x or get started or whatever there is, text is sometimes half covered with a random white box that just came into existence and everything is just very very slow. Let's say I want to make an offer for my first customer. I click the button, and I decide to before that, send another message to them. So okay, I click the x button, but guess what, now nothing on the page works. Buttons don't work, chat box doesn't work and I must reload. What the hell Fiverr? Also, file previews appear painfully slow, even on a 90mbps connection. This is becoming unusable

  • Like 2
Link to comment
Share on other sites

It seems like the problem happened only with you. Here in my case it totally works just fine. I guess you should change the browser or update the previous one. It would be more clear to us if you state your system details as well as browser name with the version.

  • Like 1
Link to comment
Share on other sites

Just updated to the newest Chrome version and nothing changed. I'm using Windows 11 21H2 (Build 22000.675). System information:

     - CPU: AMD Ryzen 7 3700X running currently on 3593 MHz

     - GPU: nVidia GeForce RTX 2060 6GB GDDR5 VRAM

     - RAM: 32GB (16GBx2) Dual-channel DDR4 memory

     - Storage: OS currently running on a 240GB NVMe SSD (Chrome installed on it too), 1TB M.2 SSD and 1TB 7500RPM SATA 6GB/s HDD

  • Like 1
Link to comment
Share on other sites

1 hour ago, balonko said:

I've just started selling on Fiverr, and was pretty happy on how it went. But, after a day or two, there were major flaws. Every single popup box disables page navigation, even if clicked on x or get started or whatever there is, text is sometimes half covered with a random white box that just came into existence and everything is just very very slow. Let's say I want to make an offer for my first customer. I click the button, and I decide to before that, send another message to them. So okay, I click the x button, but guess what, now nothing on the page works. Buttons don't work, chat box doesn't work and I must reload. What the hell Fiverr? Also, file previews appear painfully slow, even on a 90mbps connection. This is becoming unusable

Have you tried clearing your browser cache? 

Since we can't replicate the issue on our end, it's most likely a local issue with your browser (considering your PC specs it's not a hardware issue haha). 

Alternatively, you can try a different browser, like Edge, to see if you have the same problem there. 

  • Like 1
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...