Jump to content
  • 0

Is anyone having problems with milestones?


ken87ken
 Share

Question

Hi, I did a milestone order with my client. We completed the first one, and the client accepted it and approved the second one. But the order page still shows no progress on the second milestone and I can't even see the delivery button. Is anyone experiencing this?

  • Like 5
  • Sad 2
  • Up 2
Link to comment
Share on other sites

2 answers to this question

Recommended Posts

  • 0

Hi. I don't remember the exact issue, but the last time I used the feature, there was indeed something ultra-confusing going on, so much that I decided to not use it again. I think it fell together with the launch of the new Order Page, so it might have had something to do with that. Maybe click all the Order Page tabs (Activity, Details, Requirements, Your Order Details) (again), to make sure nothing is hiding anywhere, before you may have to contact support.

  • Like 6
Link to comment
Share on other sites

  • 0
13 hours ago, miiila said:

Hi. I don't remember the exact issue, but the last time I used the feature, there was indeed something ultra-confusing going on, so much that I decided to not use it again. I think it fell together with the launch of the new Order Page, so it might have had something to do with that. Maybe click all the Order Page tabs (Activity, Details, Requirements, Your Order Details) (again), to make sure nothing is hiding anywhere, before you may have to contact support.

Thank you. I have also decided not to use the feature anymore. I also suspect it confuses the buyers, especially those new to the platform. It's better to discuss with the buyer and send as many smaller orders until the project is complete. 

  • Like 4
  • Up 1
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...