Jump to content

Can't visit Fiverr.com using Chrome - "Your connection is not private"

Recommended Posts


Today I have tried to visit Fiverr.com using Google Chrome Browser. But “Your connection is not private” thing happened. I have reset the chrome. Deleted all cookies. But no luck! I tried it using incognito mode but the same thing. But when I have tried Firefox Browser. I the site is visible with no problem.

Can I know what is this? Is it a error from chrome or fiverr?

Thank you!

Link to comment
Share on other sites


Done, but no luck! Are you using Chrome?

Yes, if I do have a problem, I just uninstall chrome and reinstall it, have you tried the proxy in settings?

Also turn off all extensions, one by one and then try

when you type “Your connection is not private” the first result is google chrome help and they give you many possibilities

Link to comment
Share on other sites

  • 10 months later...

Make sure your time and date are sync
Sending resync command to local computer
Command : w32tm /resync

if it is sync and still getting error

i do recommend clear some cache on your browser and update it. sometimes this issue will it it if not i found another solution and it works as well following solution No.2 from this website https://www.**********/error/your-connection-is-not-private-chrome-error/ to sort this issue out.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...